LC9 Trigger not resetting

The place to discuss the inner workings of firearms.

Moderators: Bullseye, Moderators

Post Reply
Uncle TK
New member
New member
Posts: 4
Joined: Mon Oct 07, 2013 9:58 pm
Location: OKC

LC9 Trigger not resetting

Post by Uncle TK » Tue Oct 08, 2013 7:42 am

New LCP requires me to pull trigger back at least 1/2 way then release trigger and then pull to fire.

When I take the slide off and cock the hammer with my thumb it fires correctly but when I put slide back on, the trigger will not reset with out pulling it and releasing it.

Any ideas?

User avatar
Bullseye
Site Admin/Host
Site Admin/Host
Posts: 6371
Joined: Sun Aug 14, 2005 12:23 pm
Location: USA

Post by Bullseye » Tue Oct 08, 2013 5:01 pm

Sounds like issues with the disconnector. The slide has to be fully closed for the disconnector to allow the trigger to fire the pistol and prevent an out-of-battery detonation. With the slide off, the disconnector operates as if the slide is closed and the disconnector lever is in the slide pocket for being in the fully closed position and allowing the trigger to operate the hammer. This is where I'd look.

R,
Bullseye
Image

Uncle TK
New member
New member
Posts: 4
Joined: Mon Oct 07, 2013 9:58 pm
Location: OKC

Post by Uncle TK » Tue Oct 08, 2013 7:19 pm

Thanks Bullseye
Cleaned out plunger in slide with Gun Scrubber, the second time, it was gummed up.

I had installed a Belt Clip (See Below Link) if you tighten the allen set screw too tight it causes a reset problem.

http://www.amazon.com/gp/product/B008AD ... UTF8&psc=1

User avatar
Bullseye
Site Admin/Host
Site Admin/Host
Posts: 6371
Joined: Sun Aug 14, 2005 12:23 pm
Location: USA

Post by Bullseye » Tue Oct 08, 2013 8:57 pm

That makes sense with your problem description, since that is the side of the pistol where the disconnector is located. Glad to hear you have the problem resolved. Have fun shooting your LCP.

R,
Bullseye
Image

Post Reply